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Overview

For years, Microsoft Access has enabled developers to create database applications that address a specific business need, task, or process. In Access 2010, applications are now modern-looking right out of the box – no customization necessary. Access, through Access Services in SharePoint 2010, is now on the web – developers can create and share databases online. The web is also integrated within Access with mashup-type web functionality within Access applications. To use this new functionality, developers need to be aware of the differences among web databases, client-only databases, and hybrid databases. 
Objectives
The objectives of this Hands-On Lab are to acquaint the reader with new developer related features of Access 2010 with a keen emphasis on understanding the differences between developing database objects that will work in a Web database versus objects that work only in a client database.
Understand the benefit of starting from templates
Learn basic data design modifications for Web databases
Develop an understanding of Web form modification and creation
Learn how to use Navigation forms
Learn how to use the new macro editing environment

System Requirements
You must have the following items to complete this lab:
Microsoft Access 2010

[bookmark: _Toc157870738]Online Resources
Additional Online Resources:
Microsoft Access Team Blog
http://blogs.msdn.com/access 
Access 2010 Intro Series Blog posts
http://blogs.msdn.com/access/archive/tags/2010+Intro+Series/default.aspx
Access 2010 Macro Designer
http://blogs.msdn.com/access/archive/2009/07/28/meet-the-access-2010-macro-designer.aspx 
Access 2010 Data Macros
http://blogs.msdn.com/access/archive/2009/08/13/access-2010-data-macros-similar-to-triggers.aspx 
Tutorial: Publish an Access 2007 Database to the Web
http://channel9.msdn.com/shows/Access/Tutorial-Publish-a-Access-2007-database-to-the-web/ 
The Access Show on Channel 9
http://channel9.msdn.com/shows/Access/ 
 
Setup
There is no special setup for this lab.

Exercises
This Hands-On Lab comprises the following exercises:
Modifying the table structure of a Web Database
Web Database Form Modification
Web Database Form Creation and Navigation
Creating a Data Macro
Publish a Database to the Web (Optional)

Estimated time to complete this lab: 60 minutes.
[bookmark: _Toc166647553][bookmark: _Toc172462715][bookmark: _Toc182141329]Starting Materials
This Hands-On Lab has no starting materials.
Exercises 1-5. There are no starting materials for these exercises.
Note: See the Completed Files folder for a completed example of the Job Applicant database.

Exercise 1: Modifying the table structure of a Web database

Access 2010 templates are accessible from Access Backstage and are ready-to-use and free database solutions complete with tables, queries, forms, and reports built for common scenarios. In addition to the templates shipped with Access 2010, there are numerous third party templates available at office.com.
Many times, you may find that it is much easier to customize a template to a customer’s unique needs rather than start from scratch. In this exercise, you will learn how to perform tasks related to template customization and save development time. 
Consider the needs of a human resources manager who needs to track job applicants. A good place to start in a situation like this is to see if there are any templates available that you could use as a starting point. In Access 2010, the Contacts Web Database template serves as an excellent starting point for a job applicant tracking system. Since the purpose of this exercise is to get experience modifying web database objects, we will use the Contacts Web Database template as a starting point for this exercise.
[bookmark: _Toc250827046][bookmark: _Toc250827559][bookmark: _Toc289157724]Task 1 – Create an Access Table
One common customization task when starting with a template is to modify the structure of existing tables in the template to suit your unique needs. Besides generic contact information, a job applicant tracking system needs to keep track of the details of the jobs that are available. In the first task, you will create a new database based on the Contacts Web Database template and then create a new table called Jobs for tracking available job details. 
Open Microsoft Access 2010
Click on Sample templates
Select the Contacts Web Database
Change the File Name on the right side to Job Applicants
Click Create
[image: ]
Figure 1
Available Templates

Check out the various items in the database. In particular, check out the four tabs:
Address Book – shows list of contacts and details of selected contact
Datasheet – shows a list of contacts in data sheet view
Report Center – shows a list of available reports and currently selected report
Getting Started – provides links to helpful information
Close the Main tab by right-clicking on the tab and choosing Close
Expand the Navigation Pane. The navigation pane is the pane on the left-hand side of the application window that shows objects in the database. You can hide/show this pane by clicking on the “>>” button in the top-right corner of this pane.
Take a minute and review the Tables, Queries, Forms, and Reports in the database
Create the Jobs table. The Jobs table is a table that contains fields for storing the details related to the available positions. For example, it will store the position number, position title, status, and creation date, a description of the position, and the department of the position. As you perform these steps, keep in mind that you are working with a web database. Using web databases imposes some limitations on the types of functionality you can use in a database so that the database can run on SharePoint. The benefit of starting with a web database is that you can publish the database to the web with one click. You will notice that the design experience for creating and modifying web database objects is a little different from the design experience for modifying client only objects. To design a web table, you perform the modification in datasheet view using the functionality exposed in the Table Tools ribbon tabs. 
On the Create tab, click Table
Select the ID column, choose Name & Caption from the ribbon
Set the Name and Caption to Position Number and click OK
[image: ]
Figure 2
Field Properties

Click Click to Add in the next column and select Text. This process sets the data type of the field and highlights the column heading so that you can enter the name of the field.
Name the field Position Title
In a similar manner as steps d and e, create the following fields. The list below shows the name of the field followed by the data type in parenthesis:
Date Created (Date & Time)
Description (Memo)
Department (Text)
Create the next field using the Lookup & Relationship data type. A lookup field allows you to control the possible values for a field based on a list of possible values. Use a relationship field for establishing relationships between tables in a database. 
Select I will type in the values that I want and click Next
[image: ]
Figure 3
Lookup Field Wizard

Underneath the Col1 column heading, enter the following values: Open, Closed – filled, Closed – cancelled, Hold.
[image: ]
Figure 4
Lookup Field Values

Click Next
Set the label for the field to Status and check Limit To List
[image: ]
Figure 5
Lookup Field Label, Limit and Multiple Values Designation

Click Finish. The following screen shot shows an example of the completed jobs table after entering a few records. Notice that the Status field contains the list of values you entered in step i previously. Figure 6
[image: ]
[bookmark: _Ref250706656]Figure 6
Lookup Field in Jobs Table

Save the table as Jobs
Right-click on the Jobs tab and select Close to close the table

[bookmark: _Toc250827047][bookmark: _Toc250827560][bookmark: _Toc289157725]Task 2 – Modify the Contacts table
In addition to adding tables to a template, you often need to modify existing tables. In this task, you will modify the contacts table to store additional information related to tracking a job applicant.
Under Tables, double-click Contacts to open the Contacts table
Click on the Company column header
On the Fields tab, select Name & Caption
Change the Caption from Company to Employer. In practice, you could also change the Name of the field. Changing the name however, could break any references to the field in queries, forms, or reports. In the interest of time for this exercise, leave the name the same so that you don’t need to worry about breaking any references.
[image: ]
Figure 7
Field Properties

Click OK
Scroll to the last field in the table.
Add a new Date & Time field named  Initial Interview. (See steps 10 d-f (or 4-6 if viewing lab on the web) in Task 1 for a refresher if you need.)
Create a field for application status using the Lookup & Relationship data type
Create a value list lookup by selecting I will type in the values that I want and click Next
Enter the following values under Col1
Open
Closed – Not Qualified
Closed – Applicant Withdrew
Closed – Hired
Closed – No decision
Interviewing
Offer outstanding
Click Next
Set the label to Status and check Limit To List
Click Finish
Create a field to store the referral source using the Lookup & Relationship data type. This field will have a drop-down list that allows you to select how the applicant heard about the position.
Select I will type in the values that I want and click Next
Enter the following values under Col1
Agency
Internal Referral
Company Website
Newspaper
Other
3rd Party Website
Click Next
Set the label to Referral Source and check Limit To List
Click Finish
Create the next field using the Lookup & Relationship data type. In the next series of steps, you will create a Position column in the Contacts table that looks up position titles from the Jobs table.  You will learn to establish a relationship between the Contacts table and the Jobs table. This process is different from the process you use for client-only databases.
Select I want the lookup field to get the values from another table
[image: ]
Figure 8
Lookup Wizard

Click Next
Select Table: Jobs

Figure 9
Table Selection

Click Next
Double-click on Position Title and Position Number to transfer them to the Selected Fields list box
[image: ]
Figure 10
Field Selection

Click Next
Select Position Title in the first drop-down list to sort the values that appear

Figure 11
Sort Order

Click Next
In order to prevent the key column from appearing, ensure that Hide key column is checked

Figure 12
Set Column Width

Click Next
Set the label for the lookup field to Position

Figure 13
Lookup Field Label, Data Integrity and Multiple Values Designation

Click Finish
Close and save the table.

[bookmark: _Toc250827048][bookmark: _Toc250827561][bookmark: _Toc289157726]Exercise 1 Verification
In order to verify that you have correctly performed all steps of exercise 1, proceed as follows:
Open the Jobs table
Add records to the table as shown below. Observe how the Status field is limited to the values you specified when setting up the table.

Figure 14
Status Field

Save and close the Jobs table
Open the Contacts table
Add a few records to the table – see suggested records below (do not worry about fields not shown). Note that the records below are in a vertical layout rather than the horizontal layout of your table. This is simply because there is not enough width in this page to view the records in a horizontal layout.
Observe how the Status and Referral drop-down fields are limited to the values you specified when setting up the table. Also, note how the Position field is limited to position titles from the Jobs table.

Figure 15
Data for Contacts Table

Save and close the Contacts table
Open the Main form by double-clicking on it in the Navigation Pane
Click on the Address Book tab
Click on each of the names you entered in step 5 above. Observe how the details associated with each applicant are displayed in the window. 
[image: ]
Figure 16
Contact Card


Exercise 2: Modifying a Web form

Just as the procedures for creating and modifying Web database tables are different, so are the procedures for creating and modifying Web database forms. The most pronounced difference is that instead of using the design view to create and modify forms, you use a view called the layout view. The layout view debuted in Access 2007. One of the advantages of the layout view is that you can design a form in a WYSIWYG fashion with a live preview of the data.
In this exercise, you will modify a couple of the forms in the database that are used to display and update information associated with a particular job applicant.
[bookmark: _Toc250827050][bookmark: _Toc250827563][bookmark: _Toc289157728]Task 1 – Modify the ContactsExtended query
In Exercise 1, you added some fields to an existing table in the database and added a new table. In order to use these new items in forms, you will modify the ContactsExtended query to reflect the new additions.  You will also add a join to the Jobs table to include the Position Title in the query result.
Right-click on the query ContactsExtended and select Design View
In the Design tab of the ribbon, click on Show Table 
Select Jobs and click Add. Observe that Access adds the Jobs table to the query designer and the relationship between the tables is apparent. Click Close.
Right-click on the relationship (the line between the two tables) and select Join Properties
Select the option labeled Include ALL records from ‘Contacts’ and only those records from ‘Jobs’ where the joined fields are equal. Click OK. This creates a left join so that all contacts are returned regardless of whether there is a value specified in the position field.
Click on Close
From the Jobs table, double-click on Position Title to add it to the results of the query
From the Design tab, click Run to view the query results. Verify that the Position Title field is in the results.
Close the ContactsExtended query saving your changes

[bookmark: _Toc250827051][bookmark: _Toc250827564][bookmark: _Toc289157729]Task 2 – Modify the NameCard form
The NameCard form is used as a sub-form on the Main form. In this task, you will modify it to show more information about the job applicant.
Right-click on the NameCard form in the Navigation Pane and select Layout View
If the Property Sheet pane is not visible, show it by clicking Property Sheet from the Tools group on the ribbon.
In the Property Sheet, select Form from the drop-down list
On the Data tab, change the Record Source property from Contacts to ContactsExtended
[image: ]
Figure 17
Record Source Property

Add the applicant’s status to the form
Select the cell containing the applicant’s name
Click on the Arrange tab on the ribbon
Select Split Horizontally
On the Design tab of the ribbon, select Add Existing Fields 
Drag and drop Status from the field list to the new cell you just created next to the applicant’s name.
Select the cell containing the label reading Status and press Delete
Drag and drop the cell containing the Status value and move it one cell to the left
[image: ]
Figure 19
Move the Status Cell

On the Property Sheet, set the value of the Width property (on the Format tab) to 2.26 or simply drag the guidelines to reduce the size to an appropriate width.
Using the Format tab of the ribbon, set the font size to 14, change the font color to red, and turn off the Bold format.
On the Arrange tab of the ribbon, select Control MarginsMedium to center the text vertically in the cell
[image: ]
Figure 20
Status Cell with Modified Property Values

Directly below the applicant’s name, it would be helpful to see the position they are applying for along with the position number (in case there is more than one position available with the same position title). In order to do this, we are going to repurpose the job title text box (txtJobTitle) so that it uses an expression rather than being directly bound to a field value. Perform the following steps to do this.
Select the cell immediately below the applicant’s name
Click on the Data tab of the Property Sheet
Put the cursor in the Control Source property and then click on the ellipses or (…) that appears to display the Expression Builder
Delete JobTitle and enter  =[Position Title] & " (" & [Position] & ")". This formula concatenates the values of the Position Title and Position fields so that you can display them together in a single cell. 
To eliminate potential confusion, clear the Default Value property
Click OK
[image: ]
Figure 21
txtJobTitle

Two rows beneath the applicant’s name, you will add the referral source and initial interview date. Begin by selecting the cell two cells beneath the applicant’s name
Using the Property Sheet, set the Height of the cell to 0.25”
[image: ]
Figure 22
Add Referral Source Cell

On the Arrange tab, select Split Horizontally
On the Design tab, select Add Existing Fields
Drag and drop the Referral Source field from the Field List to the row, dropping it in the cell highlighted below.
[image: ]
Figure 23
Drag and Drop Referral Source

[image: ]
Figure 24
Adjust Dropdown List to the Left

Highlight the cell containing the label Referral Source and press Delete.
Drag and drop the Referral Source one cell to the left.
[image: ]
Drag and drop the Initial Interview field from the Field List to the cell immediately to the right of the referral source cell
Select the cell containing the Initial Interview label and press Delete
Drag and drop the drop-down list containing the Initial Interview field and move it one cell to the left. Note that if the current record doesn’t have an initial interview date, nothing will appear in the cell. However, if you view the Property Sheet, you should see that the cell contains a text box with the Control Source property set to Initial Interview
[image: ]
Figure 25
Initial Interview

Press Ctrl + S to save your work (alternatively right-click on the form tab and select Save). 
Close the form

[bookmark: _Toc250827052][bookmark: _Toc250827565][bookmark: _Toc289157730]Exercise 2 Verification
In order to verify that you have correctly performed all steps of exercise 2, proceed as follows:
Double-click on the form named Main in the Navigation pane to open the form
If you modified the NameCard form as listed, you should see a navigation form containing a NameCard sub-form showing the selected applicant’s details complete with applicant status, position title and number, referral source, and initial interview date if any.
Navigate to the various Applicants you have entered by clicking on their name in the applicant list (highlighted in red below) on the left side of the Main form. 
[image: ]
[bookmark: _GoBack]Figure 26
Contact Card with Modifications


Exercise 3: Creating a new Web database form

In this task, you will create a new Web form for viewing information from the Jobs table that you created in Exercise 1. In addition, you will modify the main navigation form to include a link to the new job viewing form. A navigation form (not to be confused with the Access navigation pane) is a new feature in Access 2010. Navigation forms enable database developers to provide a structure for users so that they can access relevant database objects as needed. Navigation forms are the glue that transforms a database into an application rather than some unorganized collection of tables, reports, queries, and forms.
[bookmark: _Toc250827054][bookmark: _Toc250827567][bookmark: _Toc289157732]Task 1 – Create the Jobs form
Select Jobs table in the Navigation pane
In the Forms group of the Create tab, click on Multiple Items
[image: ]
Figure 27
Multiple Items

Observe that Access creates a form for you. This form displays all items from the Jobs table and allows you to edit items.
Adjust the height and width of the columns.
Place the cursor in any cell in the Position Title column
Choose Select Column from the Arrange tab on the ribbon
Adjust columns by dragging the edge to reduce the column width.  Adjust rows by dragging the bottom edge to reduce the height.
From the drop-down list at the top of the Property Sheet, select FormHeader 
Set the value of the Back Color to Accent 1, Lighter 40%. Click on the ellipsis button in the Back Color property and select the color shown in the 3rd row of the 5th column.
[image: ]
Figure 28
Set Back Color

On the Design tab in the ribbon, select ViewForm View. Observe that in a few simple steps, you have created a functional form.
[image: ]
Figure 29
Form View

Save and close the form
Close the Jobs form

[bookmark: _Toc250827055][bookmark: _Toc250827568][bookmark: _Toc289157733]Task 2 – Modify the Navigation form
Now that you have successfully created the form, you need to give users an easy way to get to it. In this next task, you will modify the main navigation form so that it contains a link to the Jobs form.
Open the Main form in Layout view. Note that if you had the Main form open when making changes to the Jobs form in the previous task, you need to close the Main form and re-open it to see the changes you made to the Jobs form.
Drag the Jobs form from the Navigation pane and drop it in between the Address Book tab and Datasheet tab
[image: ]
Figure 30
Drag Jobs Form to Navigation Tabs

Observe that Access modifies the Navigation pane and shows the Jobs form
[image: ]
Figure 31
Jobs Form

Press Ctrl + S to save your work

Exercise 4: Creating a Data Macro

One of the most exciting new areas of Access 2010 involves the new Macro Designer as well as the new data macros. The new Macro Designer provides developers with a much easier and efficient environment to work in. Data macros meanwhile, provide developers with a way to centralize business logic by attaching macros to table data events. Data macros are similar to triggers in SQL Server. Rather than embed business logic throughout your forms, you can associate Data Macros with tables so that anytime a user updates a table, your business logic executes at the appropriate time. 
In Exercise 4, you will get some experience using the new Macro Designer to build a data macro that enforces some business logic on the Job Applicant database.
[bookmark: _Toc250827057][bookmark: _Toc250827570][bookmark: _Toc289157735]Task 1 – Create a Macro to limit Offers Outstanding
In task 1 you will create a data macro that helps prevent HR from accidentally making multiple, simultaneous offers for the same position. Specifically, the macro will prevent someone from changing an applicant’s status to Offer Outstanding if there is already an applicant with an outstanding offer for the same position.
Open the Job Applicant database that you used for Exercise 3
Open the Contacts table
Click on the Table tab of the ribbon. Note the Before and After events associated with the table that you can attach data macros to.
[image: ]
Figure 32
Table Tab

Click on Before Change 
In the drop-down box on the Logic Designer (the design time environment for Macros), select the If item to create a (If…Then) statement. The Before Change event occurs anytime there is a change made to the table – specifically, just before the change is committed. For the needs of this macro, you only need to consider the changes to the table where the record changed contains the value “Offer Outstanding” for the Status. You will use this initial (If…Then) statement to perform this check. 
In the If field type St and notice that IntelliSense appears with potential objects of interest. Select the Status item. Notice that the Macro Designer adds the brackets around the name for you.
After [Status] type =”Offer Outstanding”
[image: ]
Figure 33
If Statement

In the dropdown under Then, select SetLocalVar from the drop-down box. SetLocalVar allows you to create or modify a local variable. For this macro, you’ll create a local variable named ItemID that stores the ID of a conflicting record (if there is one).
Set the value of the Name argument to ItemID
Set the value of the Expression argument to 0. Later in the macro, you will check the value of ItemID and if it is anything other than 0, you will raise an error.
[image: ]
Figure 34
SetLocalVar

Below the SetLocalVar step, select LookupRecord as the next action. Observe that the designer adds a Lookup Record block.
Choose Contacts from the Look Up a Record In drop-down box
For the Where Condition, enter [Status]="Offer Outstanding" and [Contacts].[Position]=[Position] and [Contacts].[ID]<>[ID] - the condition is true when there is an outstanding offer on the same position for a different applicant.
For the Alias argument, enter ExistingOffer
[image: ]
Figure 35
Lookup Record

Within the Lookup Record block, add a new SetLocalVar action. The purpose of this step is to record the ID of the conflicting record (if one is found).
Name: ItemID
Expression: [ExistingOffer].[ID]
[image: ]
Figure 36
SetLocalVar

The final step is to raise an error if there is a conflicting record. Click on Look Up a Record In on the designer surface to highlight this block of actions. This makes it easier to see the correct location to place the next action. For the next step, you want to use the highlighted drop-down list below.
[image: ]
Figure 37
Raise an Error

Below the Lookup Record block but before the End If statement, add a new If action.
Set the Conditional Expression argument to [ItemID]<>0
Within this If block, add a new RaiseError action
Error Number: -5000
Error Description: There is already an offer outstanding for this position
At the very end of the macro, add a new Comment action. This is how you embed comments in the design surface for future reference.
Enter the following comment: This macro ensures that only one applicant per position can have a status of “Offer Outstanding”.
Ideally, this type of comment would be at the beginning of the macro. To do this, 
Click outside of the comment so that it is no longer selected
Drag the comment to the top of the designer
[image: ]
Figure 38
Completed Data Macro

Close the Before Change macro by clicking Close on the ribbon
Click Yes to save your changes

[bookmark: _Toc250827058][bookmark: _Toc250827571][bookmark: _Toc289157736]Exercise 4 Verification
Data macros are helpful because they centralize business logic at the data level rather than duplicate it throughout the UI. To demonstrate this, you’ll verify this Exercise twice – the first time directly on the table and the second time using one of the forms in the database

[bookmark: _Toc250827059][bookmark: _Toc250827572][bookmark: _Toc289157737]Verification Task 1 – Verify directly on the table
In order to verify that you have correctly performed all steps of exercise 4, proceed as follows:
In the Contacts table, change the Status of the first two records in the table to Open
Change the Position of the first two records in the table to Sales Manager (or some other Position that you have entered). Scan the table to verify that there is not any Offer Outstanding for this position. Observe that you were able to make these changes without any errors. This demonstrates that the macro is not interfering in places that it should not.
Change the Status of the first record in the database to Offer Outstanding. Observe that you can make this change since it is the only offer outstanding for this position.
Change the Status of the second record to Offer Outstanding. Note that Access does not attempt to commit any changes until you move off the record.
Click on another record in the table. Observe that an error message is generated:
[image: ]
Figure 39
Error Message Verification

Click OK to dismiss the error
Change the Status of the record back to Open
For the next verification task, make a mental note of the two names you have been using for this verification.
Close the Contacts table

[bookmark: _Toc250827060][bookmark: _Toc250827573][bookmark: _Toc289157738]Verification Task 2 – Verify using a form
Open the Main form
On the left hand side of the form, click on the Name of the applicant whose Status is Open.
Change the Status to Offer Outstanding. Observe that Access does not attempt to commit the change until you move off the record.
Click on a different name on the left hand side of the form. Observe that Access attempts to commit the record and executes the logic in the Before Change event macro.
[image: ]
Figure 40
Error Message Verification

Click OK to dismiss the error message
Change the Status back to Open


Exercise 5: Publish a Database to the Web (Optional)
Exercise 5 is an optional exercise because you may not have an environment readily available to publish your database to SharePoint 2010 Access Services. However, this exercise shows the simple steps in doing so. Whether you are publishing your application to an on premises SharePoint 2010 site or a hosted service SharePoint site, the process is the same. If you do not have a SharePoint environment setup locally, you can use Bing and search on “Microsoft Access 2010 Hosting” for hosting services that offer Access Services.

Note: If you have Access 2007 databases that you would like to publish to the web, check out this video tutorial for guidance, http://channel9.msdn.com/shows/Access/Tutorial-Publish-a-Access-2007-database-to-the-web/.

[bookmark: _Toc289157740]Task 1 – Publish to SharePoint 2010 Access Services
Navigate to Backstage via the File tab and click Options.
[image: ]
Figure 41
Backstage View

Select Current Database and then choose Main to be the starter Web Display Form for the web user experience and click OK. (Follow any subsequent prompt instructions accordingly.)
[image: ]
Figure 42
Access Options

In Backstage view, click Publish to Access Services.
[image: ]
Figure 43
Publish to Access Services

To confirm your database is web compatible, click Run Compatibility Checker. (There should be no errors since this lab’s exercises use web compatible objects. If you receive errors, fix them and continue. If you are prompted to close open objects, close them and run the compatibility checker again.)
[image: ]
Figure 44
Run Compatibility Checker

Type your SharePoint 2010 Server URL, Site Name (JobApplicants in this case) and click Publish to Access Services.
[image: ]
Figure 45
Publish to SharePoint 2010 Access Services Site

Access shows the publishing progress.
[image: ]
Figure 46
Publishing Progress Dialog

When publishing is complete, the Publishing Succeeded dialog will display. Click the link to access the site.
[image: ]
Figure 47
Publish Succeeded Dialog

View your new web application in SharePoint 2010!
[image: ]
Figure 48
Web Application


Summary

In this Hands-On Lab, you learned about some of the primary types of tasks you will use as you customize, design, and develop Access 2010 databases. In particular, you learned how to modify key database objects using new functionality that allows you to create Web databases, a key new feature of Access 2010. You also saw how to jump-start your development efforts by using a database template. Lastly, you could see the simple steps for publishing your application to SharePoint 2010 Access Services, whether SharePoint is on premises or provided by a hosted service.
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