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Overview
In these exercises, you will learn about the BI offerings in SharePoint 2010.  You will start by performing simple visualization of existing list data using the Chart Web Part.  You will then use Excel to analyze external internet sales data and then post your results on SharePoint using excel services.  Based on that work you will finish by creating a complete dashboard used to monitor reseller sales and track actual versus expected year to date sales numbers.
Objectives
In this lab you will:
Learn to use the Chart Web Part
Learn to publish Excel Workbooks to Excel Services for viewing in the browser
Learn to use PerformancePoint Services to build rich dashboards to analyze business information
1. 
[bookmark: _Toc157870738]System Requirements
This lab assumes that you have SharePoint Server installed in a test environment. For guidance on how to setup SharePoint Server see http://msdn.microsoft.com/en-us/library/ee554869(office.14).aspx. Note that any URL referred to in this lab must be adjusted for use with your local setup.  You must have the following items to complete this lab:
Microsoft® Windows® Vista SP1 or Microsoft® Windows Server 2008 (64-bit)
Microsoft® SharePoint Server 2010 (64-bit)
Microsoft® Office Professional Plus 2010 (32-bit or 64-bit)
Microsoft® Visual Studio 2010
1. 
Setup
You must perform the following steps to prepare your computer for this lab. This consists primarily of creating a SharePoint site collection at http://intranet.contoso.com/sites/BIApplications and installing the code snippets for this lab.
[bookmark: _GoBack]Run the command file Setup.bat located at %Office2010DeveloperTrainingKitPath%\Labs\BIApplications\Source\.

Exercises
This Hands-On Lab is comprised of the following exercises:
Using the Chart Web Part
Performing Analysis with Excel and Excel Services
Building a Dashboard with PerformancePoint Services
1. 
Estimated time to complete this lab: 60 minutes.
Exercise 1: Using the Chart Web Part
In this exercise you have received some summary sales information that must be presented on the current BI Center SharePoint site.  You’ll be using the Chart Web Part to quickly visualize the sales data currently stored in lists.
[bookmark: _Toc247966857][bookmark: _Toc289157683]Task 1 – Add the Chart Web Part to the page
In this task, you will create a new web part page in the SharePoint site and place a chart web part on it.
2. In Internet Explorer navigate to http://intranet.contoso.com/sites/BIApplications
2. Create a new Web Part Page in the Pages document library
1. Click the All Site Content link in the left side Navigation menu
1. Click the Create button
1. Filter by Page, select Web Part Page and click Create
[image: ]
Figure 1
Create Dialog

1. Name the page ChartWebPart and select a layout of Full Page, Vertical
1. Select Pages in the Document Library dropdown and click Create
[image: ]
Figure 2
Create Web Part Page

2. Add a Chart Web Part to the new page
2. Click the Add a Web Part link in the content section of the page
2. Select a Category of Business Data in the Categories section
2. Select Chart Web Part in the Web Parts section and click Add
[image: ]
Figure 3
Add Chart Web Part
1. 
[bookmark: _Toc247966858][bookmark: _Toc289157684]Task 2 – Create a Sales by Country Pie Chart
In this task, you will attach list data to the Chart Web Part and then apply formatting to build a pie chart.
3. Connect the Chart Web Part to the data in the Sales by Country list
0. Click the Data & Appearance link on the Chart Web Part
0. On the new page, click the Connect Chart to Data link
0. Choose the Connect to a List option and click Next
0. Choose the Sales by Country list in the List drop down and click Next
[image: ]
Figure 4
Choose Chart Data Source List

0. Don’t assign a data filter and click Next
0. When choosing the bindings of data to field, verify the Y field is set to Sales Revenue and the X Field is set to Country
[image: ]
Figure 5
Set Chart Data Bindings

0. Click the Finish button to complete the wizard
[image: ]
Figure 6
Complete Bar Chart

3. Customize the chart to render as a 3D pie chart
1. Click the Data & Appearance link on the Chart Web Part
1. On the new page, click the Customize Your Chart link
1. On the Select Chart Type wizard page, select Pie as the Chart Type Category
1. Choose the 3D Chart Types and pick the first pie chart template and click Next
[image: ]
Figure 7
Choose Pie Chart Type

1. Set the Width to 800px and the Height to 400px and click Next
1. On the Chart element properties wizard page check the Show Legend check box
1. Set the Title to Sales By Country
[image: ]
Figure 8
Add Chart Legend

1. Click the Finish button to complete the wizard
[image: ]
Figure 9
Complete Pie Chart
1. 
[bookmark: _Toc247966859][bookmark: _Toc289157685]Task 3 – Create a Sales by Year Chart
In this task, you will attach list data to the Chart Web Part and then apply formatting to build a pie chart.
4. Create a new Chart Web Part on the ChartWebPart page
0. Click the Add a Web Part link in the content section of the page
0. Select a Category of Business Data in the Insert section
0. Select Chart Web Part in the Web Parts section and click Add
[image: ]
Figure 10
Add Chart Web Part


4. Connect the Chart Web Part to the data in the Sales by Year list
1. Click the Data & Appearance link on the Chart Web Part
1. On the new page, click the Connect Chart to Data link
1. Choose the Connect to a List option and click Next
1. Choose the Sales by Year list in the List drop down and click Next
1. Don’t assign a data filter and click Next
1. When choosing the bindings of data to field, verify the Y Field is set to Sales Revenue, the X Field is set to Year, and the Group by Field is set to Country
1. Click the Finish button to complete the wizard
4. Customize the chart to render as a line chart
2. Click the Data & Appearance link on the Chart Web Part
2. On the new page, click the Customize Your Chart link
2. On the Select Chart Type wizard page, select the Line as the Chart Type Category
2. Choose the 2D Chart Types and pick the Line with no margin chart template and click Next
2. Set the Width to 800px and the Height to 400px and click Next
2. On the Chart element properties wizard page check the Show Legend check box
2. Set the Title to Sales By Year
2. Click the Finish button to complete the wizard
[image: ]
Figure 11
Add Chart Web Part

Exercise 2: Performing Analysis with Excel and Excel Services
In this exercise you need to perform a quick analysis of internet sales data.  Your analysis can easily be done in Excel using a connection to Analysis Services.  Once the analysis tables are completed you will post them to the BI Center SharePoint site so others can view your results.
[bookmark: _Toc247966861][bookmark: _Toc289157687]Task 1 – Create a Pivot Table in Excel
In this task, you will create a new Excel workbook containing a pivot table based on data in Analysis Services.
4. Open Excel 2010 to create a new workbook
4. Add a data connection to the Adventure Works cube in the Adventure Works DW 2008 database
4. Click the From Other Sources -> From Analysis Services button in the Data ribbon
4. In the dialog enter demo2010a as the server name and click Next
4. In the Select Database and Table dialog, choose a database of Adventure Works DW 2008
4. Choose a cube of Adventure Works and click Next
4. In the last page of the wizard, click the Authentication Settings button
4. Choose the None authentication option and click OK
Note: Choosing None as the authentication option instructs Excel Services to use SSS to retrieve the credentials.  Excel Services has been preconfigured to use a specific SSS ID when an authentication type of None is selected.

4. Click Finish to create the data connection
4. Using the Import Data dialog automatically displayed, create a new pivot table in the main worksheet
5. Verify PivotTable Report is selected
5. Verify the data is placed in the existing worksheet at =$A$1
5. Click OK to create the pivot table
[image: ]
Figure 12
Import Data Dialog

4. Add a measure of Internet Sales Amount and the Geography and Calendar dimensions to the pivot table
6. In the PivotTable Field List task pane, choose Internet Sales in the Show fields related to drop down
6. Find Internet Sales Amount in the check box list and check it
[image: ]
Figure 13
Choose Internet Sales Measure

6. Find Customer Geography in the check box list and check it
[image: ]
Figure 14
Choose Geography Dimension

6. Find Date.Calendar in the check box list and check it
[image: ]
Figure 15
Choose Date Dimension

6. At this point your pivot table should look like this
[image: ]
Figure 16
Complete Pivot Table
1. 
[bookmark: _Toc247966862][bookmark: _Toc289157688]Task 2 – Add Sparklines to compliment the Pivot Table 
In this task, you will use Sparklines to highlight trends in data and identify min\max values with special formatting.
5. Filter the pivot table to show all months in 2002 only
0. Click the drop down arrow in the Column Labels cell (B1)
0. In the filter drop down uncheck all years except  CY 2002 and click OK
[image: ]
Figure 17
Year Dimension Filter

0. Click the plus by CY 2002 (B2) to drill into the year
0. Drill into H1 CY 2002 (B3) and H2 CY 2002 (C3)
0. Drill into Q1  CY 2002 (B4), Q2 CY 2002 (C4), Q2 CY 2002 (E4), and Q2 CY 2002 (F4)
0. Right click the January 2002 node and select Show/Hide Fields and click:
5.  Calendar Year
5. Calendar Semester
5. Calendar Quarter
[image: ]
Figure 18
Filtered Pivot Table

5. Add Sparklines for all countries using the data from B3:M8
1. Copy the country names from cells A3:A8 to A12:A17
1. Select the cells from B12:B17
1. In the Insert ribbon click the Line button in the Sparklines group
1. In the dialog choose a Data range from B3:M8
[image: ]
Figure 19
Create Sparklines Dialog

1. Click OK to create the Sparklines
[image: ]
Figure 20
Sparklines

5. Update the formatting of the Sparklines to highlight the min and max points
2. Make sure cells B12:B17 are selected
2. In the Sparkline Tools Design tab, click Marker Color -> High Point and choose a color of yellow
2. In the Sparkline Tools Design tab, click Marker Color -> Low Point and choose a color of green
[image: ]
Figure 21
Sparklines with Min/Max
1. 
[bookmark: _Toc247966863][bookmark: _Toc289157689]Task 3 – Publishing the Excel Workbook to Excel Services
In this task you will publish the Excel Workbook to SharePoint and viewing it using Excel Services
6. Publish the Excel Workbook to Excel Services
0. Click the Backstage button (labeled as File) to open backstage
0. Switch to the Save & Send tab in Backstage
0. Click the Send to SharePoint option under Save & Send then click the Save As button
0. Click the Publish Options button
0. In the drop down choose Sheets and uncheck Sheet 2 and Sheet 3 to only share Sheet 1
0. Back in the Save As dialog, enter a path of http://intranet.contoso.com/sites/BIApplications/Documents/PivotTable.xlsx
0. Click Save
6. Open the PivotTable workbook in the browser
1. In Internet Explorer navigate to http://intranet.contoso.com/sites/BIApplications/Documents
1. Click the link to PivotTable to view it in the browser
[image: ] 
Figure 22
Excel Workbook in the Browser
1. 
Exercise 3: Building a Dashboard with PerformancePoint Services
In this exercise you will create a dashboard that presents information about reseller sales for Adventure Works.  This dashboard will allow users to quickly understand the status of reseller sales across geography and time to better understand the nature of sales for the year to date.
[bookmark: _Toc247966865][bookmark: _Toc289157691]Task 1 – Create the Analysis Service data source
In this task you will create a new data source connected to the Adventure Works analysis services database and tie it to the current year
7. Start the PerformancePoint Services Dashboard Designer
0. In Internet Explorer navigate to http://intranet.contoso.com/sites/BIApplications
0. Hover over Monitor Key Performance to show the related content
0. Click the Start using PerformancePoint Services link
0. Click the Run Dashboard Designer button to download and launch the designer
[image: ] 
Figure 23
PerformancePoint Services Designer

7. Create a new data connection using the Adventure Works DW 2008 analysis services database
1. Right click on the Data Connections folder and click New Data Source
1. Choose the Analysis Services template and click the OK button
1. Enter a server of demo2010a
1. Choose Adventure Works DW 2008 in the Database drop down
1. Choose Adventure Works in the Cube drop down
[image: ] 
Figure 24
Choose a Data Source

1. Switch to the Properties tab and change the Name to Adventure Works
7. Choose a Time dimension and map it to the first day of the current year
2. Switch to the Time tab
2. Choose Date.Date.Calendar in the Time Dimension drop down
2. Click the Browse button by the Member control
2. In the Select Member dialog select January 1, 2003
[image: ] 
Figure 25
Choose Time Reference Member

2. Choose Day in the Hierarchy Level drop down
2. Set the Reference Date to the first day of the current year (ex. 1/1/2010 if it is 2010)
2. Choose the time member associations for each member level
6. Calendar Year: Year
6. Calendar Semester: Semester
6. Calendar Quarter: Quarter
6. Month: Month
6. Date: Day
[image: ] 
Figure 26
Initialize Data Connection Time 

7. Save the Data Connection by right clicking it in the Workspace Browser and clicking Save
1. 
[bookmark: _Toc247966866][bookmark: _Toc289157692]Task 2 – Create a KPI to track sales performance
In this task, you will create a KPI that calculates the total sales for the month to date, quarter to date and year to date and compares them to last year’s sales plus 25%.
8. Create a new KPI to track reseller sales
0. Right click on the PerformancePoint Content folder and click New -> KPI
0. In the Select a KPI Template dialog, choose Blank KPI and click OK
0. Switch to the Properties tab and name the new KPI Performance
8. Define the actual value as Year to Date (YTD)
1. Switch to the Editor tab
1. Click the Name for Actual and rename it YTD
1. Click the 1 (Fixed values) link in the Data Mappings column for YTD
1. On the Fixed Values Data Source Mapping dialog, click Change Source
1. Select the Adventure Works data connection and click OK
1. Choose Reseller Sales Amount in the Select a measure drop down
1. Click the New Time Intelligence Filter button
1. Enter a time formula of YearToDate and click OK
[image: ] 
Figure 27
YTD Value Definition

1. Click OK to close the dialog
1. Click the (Default) link in the Number column for YTD
1. Choose Currency in the Format drop down list and click OK
[image: ] 
Figure 28
Completed YTD Value

8. Define the target value as last year’s sales plus 25%
2. Click the 1 (Fixed values) link in the Data Mappings column for Target
2. On the Fixed Values Data Source Mapping dialog, click Change Source
2. Switch to the Calculated Metric tab
2. Choose Blank Calculation and click OK
2. In the Calculated Metrics Data Source Mapping dialog, delete Value2
2. Rename Value1 to LastYearsSales
2. Click the 1 (Fixed Values) link for LastYearsSales
2. On the Fixed Values Data Source Mapping click Change Source
2. Select the Adventure Works data connection and click OK
2. Choose Reseller Sales Amount in the Select a measure drop down
2. Click the New Time Intelligence Filter button
2. Enter a time formula of Year-1 and click OK
[image: ] 
Figure 29
Target Value Definition

2. Click OK to close the dialog
2. Enter a formula of LastYearsSales*1.25
[image: ] 
Figure 30
Target Value Calculation Definition

2. Click OK to close the dialog
2. Click the (Default) link in the Number column for Target
2. Choose Currency in the Format drop down list and click OK
[image: ] 
Figure 31
Complete KPI

8. Save the KPI by right clicking it in the Workspace Browser and clicking Save
1. 
[bookmark: _Toc247966867][bookmark: _Toc289157693]Task 3 – Create a ScoreCard to contain the Performance KPI
In this task, you will create a new scorecard that will contain the Performance KPI and calculate it for each country.
9. Create a new scorecard to contain the Performance KPI
0. Right click on the PerformancePoint Content folder and click New -> Scorecard
0. Choose the Blank Scorecard template in the Standard category then click OK
0. Switch to the Properties tab and name the new scorecard Performance By Country
9. Place the Performance KPI in the scorecard
1. Switch back to the Editor tab
1. Expand the KPIs and PerformancePoint Content nodes in the Details task pane
1. Drag the Performance into the left side Drop items here block
1. Click the Update button in the Edit tab
[image: ] 
Figure 32
Scorecard with KPI
Note: Your values will be different.  They will be current to the day the Update button is clicked.

9. Add the Geography dimension to the scorecard
2. Expand the Dimensions node in the Details task pane
2. Drag the Geography dimension to the right hand side of the Performance cell
2. In the Select Members dialog right click All Geography and select Autoselect Members -> Select “Country”
[image: ]
Figure 33
Select Geography Members

2. Click the Update button in the Edit tab
2. Right click the Performance cell and select Hide
[image: ]
Figure 34
Complete Scorecard

9. Save the scorecard by right clicking it in the Workspace Browser and clicking Save
1. 
[bookmark: _Toc247966868][bookmark: _Toc289157694]Task 4 – Create a Report to display sales by year
In this task, you will create a report showing reseller sales by reseller type.  This report will connect to the scorecard and display data only for the selected country.
10. Create a new report to display reseller sales by reseller type
0. Right click on the PerformancePoint Content folder and click New -> Report
0. Choose a report template of Analytic Chart and click OK
0. Select a data connection of Adventure Works and click Finish
0. Switch to the Properties tab and name the new report Sales By Reseller Type
10. Define the report to display reseller sales grouped by reseller business types
1. Switch to the Design tab
1. Expand the Measures node in the Details task pane
1. Drag the Reseller Sales Amount item into the Bottom Axis section
1. Expand the Dimensions then Reseller nodes in the Details task pane
1. Drag the Business Type item into the Series section
[image: ]
Figure 35
Complete Report

10. Save the report by right clicking it in the Workspace Browser and clicking Save
1. 
[bookmark: _Toc247966869][bookmark: _Toc289157695]Task 5 – Create a Dashboard to connect the content
In this task, you will display the scorecard and report and connect them.  This connection will allow filtering of the report using the currently selected country from the scorecard.
11. Create a new dashboard for displaying the performance scorecard and report
0. Right click on the PerformancePoint Content folder and click New -> Dashboard
0. Choose the 2 Columns page template and click OK
0. Switch to the Properties tab and name the new dashboard Performance Dashboard
11. Add the scorecard and the report to the new dashboard
1. Switch to the Editor tab
1. Expand the Scorecards and PerformancePoint Content nodes in the Details task pane
1. Drag the Performance By Country scorecard into the Left Column
1. Expand the Reports and PerformancePoint Content nodes in the Details task pane
1. Drag the Sales by Reseller Type report into the Right Column
[image: ]
Figure 36
Complete Dashboard

11. Connect the selected country in the scorecard to the report
2. Drag the Row Member -> Member Unique Name item in the scorecard into the report
2. Verify the Connection dialog shows Member Row : Member Unique Name in the Source value drop down list and click OK
[image: ]
Figure 37
Dashboard Connection

11. Save the dashboard by right clicking it in the Workspace Browser and clicking Save
11. Deploy the new dashboard 
4. Right click it in the Workspace Browser and select Deploy to SharePoint
4. Select the Dashboards folder and click OK
1. 
[bookmark: _Toc247966870][bookmark: _Toc289157696]Exercise 3 Verification
In order to verify that you have correctly performed all steps of exercise 1, proceed as follows:

Test the Add-in
Test your add-in to confirm that it will retrieve contacts from a SharePoint List and insert a selected contact’s information into the document. Then confirm that the ribbon buttons work correctly for exporting the document to XPS and PDF format.
View the dashboard in the browser
In Internet Explorer navigate to http://intranet.contoso.com/sites/BIApplications/Dashboards/Performance Dashboard/Page 1.aspx
Select Canada in the scorecard and verify the report is updated
[image: ]
Figure 38
Completed Dashboard

Analyze sales in Canada using the decomposition tree
 Right click Warehouse bar on the report and choose Decomposition Tree
Click Warehouse and choose Date -> Calendar Year to show sales by year
[image: ]
Figure 39
Decomposition Tree

Explore the decomposition tree to explore the data

Summary
In these exercises you learned how to use the BI tools in SharePoint 2010 to analyze and present information in different ways.  The Charting Web Part can quickly provide basic visualizations of data without involving any infrastructure than the data source.  Excel Services can exposed new or existing analysis and calculations performed in Excel Workbooks.  PerformancePoint Services allows bringing rich dashboards to the web browser using tools like KPI, Scorecards, and Reports in an connected environment.  Together these tools allow SharePoint 2010 to be a platform for business intelligence.
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